Bootloader unlock always fails

Stuck at some Point? Your Lumia is already dead? Maybe others can help you!
Post Reply
Posts: 1
Joined: Sun Jul 21, 2019 9:10 pm

Bootloader unlock always fails

Post by GoodDayToDie » Sun Jul 21, 2019 11:31 pm

Apologies in advance if this is the wrong place to ask this; I've searched here and on XDA without success though.

I've got a Lumia 950 XL single-SIM (RM-1085), SIM-unlocked, operator code 000-88. It doesn't have a SIM installed at present. I'm trying to install WOA to it (I don't much care if it's dual-boot; I've already lost all data that was on it). I've got what I *think* are all the tools and drivers (it's really hard to come by the emergency download driver now; nearly all the links are broken but I found one on a fairly sketchy site and it said I already had a newer version installed). I'm using the latest version (2.8, as of this writing) of WPInternals. The phone has not been previously unlocked (rooted, yes, but only from within the OS; the bootloader was left untouched). I'm using Win10 Enterprise on Insider Fast, connected with a USB 3.0 port.

TL;DR: Every single time I try to unlock the bootloader, if I leave it long enough, WPInternals says "Failed to unlock the bootloader. It is not possible to unlock the bootloader straight after flashing" and tells me I need to reboot the phone.

I've tried this in so many states of phone I'm no longer sure I can remember them all, but the general process usually goes like this:
  1. Get the phone and PC into a state where I want to try unlocking it (this has involved numerous rounds of flashing, OOBE, updating, etc. over many hours and uncounted reboots, although most of the reboots have been of the phone).
  2. Use WPInternals to download the flashing files (I've also tried doing this when the phone is in flashing mode already; seems to make no difference).
  3. Put phone in flashing mode using WPInternals (either via manual control or through the Unlock Bootloader section). This quickly and successfully reboots the phone to a black screen with the looped-arrows icon. WPInternals shows everything related to bootloader security and secure boot as red.
  4. Hit the "unlock" button in the "unlock bootloader" section, with the latest files selected. The phone immediately reboots. If I don't do this quickly enough after switching modes, the phone reboots to normal mode instead of to flashing mode, and after trying for a while WPInternals notices that the phone is in the wrong mode. If I do it pretty immediately after entering flashing mode, the phone reboots to the red-background screen, displays a progress bar (as does WPInternals) that rapidly fills up.
  5. WPInternals then says the phone is rebooting, and the the phone does that but immediately BSODs (no message, just the frown on blue background). It then reboots and goes to the gears (progress bar visible but does not fill), while WPInternals says it's switching to mass storage mode. The phone reboots from this gears screen on its own after a few seconds (usually around this time WPInternals says it cannot detect the phone and I need to manually reboot it, but if left for a bit it reboots itself, and manually rebooting on demand doesn't seem to help). It usually reboot-loops with the gears multiple times, without returning to either the flashing screen or the BSOD.
  6. Eventually the phone gets into some kind of state where it can make progress, and starts rebooting very quickly. It'll sometimes switch to the flashing screen for a moment. The phone at this point is not in mass storage mode - it never gets there, even though that's the mode WPInternals said it was switching to - and WPInternals says it is flashing (or occasionally tells me to reboot it, often as the phone is already doing that).
  7. The phone reboots back to the main OS, successfully (no BSOD or gears) and WPInternals tells me it failed to unlock the bootloader.
If I interrupt WPInternals while the phone is bootlooping on the gears, it gets stuck in a bad state where it cannot boot. WPInternals will fail to connect unless you tell it to interrupt the boot process at the bootloader (the phone never gets far enough to connect normally). Once interrupted in the boot process, the phone goes to a flashing screen with no progress bar, and WPInternals says it is in flashing mode. It also says that Secure Boot is disabled (green), but the bootloader is still locked (red), and yet, if I click on Unlock Bootloader, it says the phone is already unlocked! Switching to mass storage mode fails, and switching back to normal mode just resumes bootlooping on the gears. Restore bootloader mode takes a good while but will eventually return the phone to usable mode (without re-flashing enough to require OOBE again).

States I've tried to unlock the bootloader from:
  • Insiders Fast ring, latest, fully configured, rooted from within the OS (bootloader untouched).
  • Build 10586 (immediately after flashing and before OOBE, after OOBE but without a MSFT account, after OOBE with a MS account but before the phone detects that there are updates to install, and same but it has started downloading updates).
  • Build 14393 (immediately after updating, after updating and letting it settle with a reboot but before downloading additional updates, and after it started downloading updates).
  • Build 15254 (immediately after updating, after settling and rebooting but no further updating, and after it successfully installed the minor patches up to .575).
Troubleshooting steps I've tried:
  • Reboot phone (SO many times).
  • Reboot PC.
  • Switch USB cables.
  • Switch USB ports (on PC).
  • Re-download files in WPInternals.
  • Flash using WDRT instead of WPInternals.
Can anybody help? Suggest a very specific state I should aim for and ideally how to get there? Suggest anything I didn't think to try, even?

Thanks so much!
0 x

Posts: 5
Joined: Wed Jul 24, 2019 2:29 pm
Location: München

Re: Bootloader unlock always fails

Post by JoachimP » Thu Jul 25, 2019 1:23 pm

probably your 950XL consieders itself still in a reset state.

There are also WoA Builds as .ffu which can be flashed as W10M firmware. Try to flash one of these ( e.g 950XL_1078.0053.18898.13169.12547.035242_woaclient_pro_en-us_prod_unlocked.ffu) (!2vQgSaKC!ahXLuT_ImsvbFmRUUDpfpQ), you do not need to unlock your boot loader I think. I used it, but returned to the Lumia WoA Deployer.

My last working path was 2 days ago:
1. Flash 10586 image
2. Setup without account
3. WOC Updates to 15254.575 (faster than wifi)
4. Unlock Boot Loader via WPInternals 2.8
5. Switch to Mass storage mode
6. Deploy WoA.

Good luck!
Best wishes,
0 x

Posts: 102
Joined: Mon Sep 02, 2019 9:17 am
x 55
x 31

Re: Bootloader unlock always fails

Post by The_GTA » Mon Sep 02, 2019 6:04 pm

Have you tried manually interrupting boot process and then changing the phone's status? Hopefully you get this problem sorted out. On my Lumia 950 I never had the gears appear to me (just red and green flashing screens). Maybe try preventing the gears by interrupting the bootloader.
0 x

Post Reply