Lumia 950 - No WiFi

Stuck at some Point? Your Lumia is already dead? Maybe others can help you!
Post Reply
cambsukguy
Posts: 2
Joined: Mon Mar 11, 2019 11:15 am
x 2

Lumia 950 - No WiFi

Post by cambsukguy » Mon Mar 11, 2019 5:05 pm

Despite some problems like OOBESETTINGSMULTIPAGE errors, I got an 1809 build running on a 950.

However, during OOBE I saw no WiFi and still have none visible.

There are 9 Qualcomm link local network adapters in the Device Manager but no Wireless adapters - troubleshooting doesn't help.

I just wondered if the 950 was supposed to have working WiFi - I assumed it was identical to the XL.
0 x

KillerMemz
Posts: 3
Joined: Thu Mar 07, 2019 3:03 am
x 1

Re: Lumia 950 - No WiFi

Post by KillerMemz » Mon Mar 11, 2019 8:28 pm

The 950 and 950XL have different SoCs, and WiFi is one of the things that doesn't work on the 950's SD808 as opposed to the 950XL's SD810.
A full list of what's working and what isn't can be found in the FAQ/Knowledgebase.
0 x

cambsukguy
Posts: 2
Joined: Mon Mar 11, 2019 11:15 am
x 2

Re: Lumia 950 - No WiFi

Post by cambsukguy » Wed Mar 13, 2019 1:27 pm

Thanks for the info but I did read the FAQ prior to posting and, whilst there is a specific mention of WiFi for the XL, there is no mention for the 950 either way, working or not.

Since the driver is likely to be similar, is there driver source code available that is currently used or was it patched in code from the original WP10 driver?

Does Qualcomm give enough information for that SOC to allow creation/porting (via their CreatePoint system)?

I am an embedded developer and (mostly) retired so I would be willing to put in some 950 effort if anyone has a HOWTO on how to set up for WOA development (is it as simple as adding a new target to Visual Studio?).
2 x

gnomomagico
Posts: 3
Joined: Fri Mar 22, 2019 10:38 pm
Location: Italy
x 2

Re: Lumia 950 - No WiFi

Post by gnomomagico » Sat Mar 23, 2019 1:36 pm

Apparently this commit is about 950 wifi:

https://github.com/gus33000/MSM8994-899 ... 2766fe7766

but I installed yesterday and the device cannot start...

I have a 950 to donate to the project for testing: it doesn't boot but it can enter flash mode. I tried reflashing with stock ffu but it doesn't boot it's stuck on microsoft logo and sometimes blue windows logo. If you can fix it it's yours.
0 x

Post Reply