Page 1 of 1

WSL 2 on Lumia 950

Posted: Mon Sep 23, 2019 11:02 am
by tslivede

As WSL 2 is now available on arm, I tried to enable it.

Installation of Windows version 18985.1_PROFESSIONAL_ARM64_EN-US was almost without problems. (Only one time during the installation the screen went black and didn't come back, so after maybe an hour I pressed the power button for 30s and then the installation continued normally.)

Installing the "Windows Subsystem for Linux" compont via Control Panel ("Turn Windows features on or off") was no problem. However after enabling the "Virtual Machine Platform" component (which changes the bootmanager entry), I can no longer boot into Windows.

It just stays at this screen:


However, sometimes it gets to this screen:


As the msm8992 seems to support virtualization I hoped that this could possibly "just work" - but as it doesn't, I don't really know where to look for problems.

Is there something that I could try, or is this for some reason just impossible?

Re: WSL 2 on Lumia 950

Posted: Sat Sep 28, 2019 10:51 pm
by The_GTA
I have just tried installing the Virtual Machine Platform on my Lumia 950 and it does not work for me either. So that should confirm that it cannot work.

But other than that, you can fix being stuck at the boot logo without redeploying your Windows 10 ARM.
Simply change into Mass Storage Mode, edit the BCD to start windows in Secure Mode (choose the BCD under the "SYSTEM" partition) and then attempt to boot. You will now see the spinning balls again which is a good sign. Let it boot for like 2 more minutes. It will be seemingly stuck at a black screen. Now forcefully shut down your phone, then switch it back to Mass Storage Mode. Edit back the BCD to perform a regular boot of Windows 10 and boot into it. You will realize that the spinning balls are back into play. After the spinning balls you will be greeted with the message: "The updates could not be applied." (or something similar). So Windows 10 will roll-back and successfully start again.

Did you know that WSL1 does work under Windows 10 ARM? I suppose you tried WSL2 just for the heck of it (kudos to you!).

Re: WSL 2 on Lumia 950

Posted: Wed Oct 02, 2019 8:47 am
by tslivede
Thanks for your reply!

Nice to know, that it can be repaired without redeploy 😀.

I wanted to try WSL2 as a first step to get anbox running (it seems, someone was trying to get anbox working on WSL 2 ...) - Android apps on a Lumia would be usefull right ;) .

I was pretty sure, that I wouldn't succeed - but at least I had to try.

Re: WSL 2 on Lumia 950

Posted: Thu Oct 03, 2019 6:20 pm
by gilius
Has anyone tried WSL2 on RPi3 or Snapdragon laptop to confirm it definitely works? And have you tried it on 1909 feature update as opposed to Insider on the Lumia?

Is there a way of building a WIM and sysprepping it first before using WOA Deployer? ... ure-deploy

For sure all ARM64 cpus support virtualization - but the bootloader needs to give access to EL2.

Re: WSL 2 on Lumia 950

Posted: Fri Oct 04, 2019 9:21 am
by tslivede
> have you tried it on 1909 feature update?

No, I assumed, that WSL 2 is only available on Insider Build 18980 and above, as the release announcement of 18980 says: "In this build, we’ve added WSL2 support for ARM64 devices!"

Re: WSL 2 on Lumia 950

Posted: Fri Oct 04, 2019 5:46 pm
by gilius
Not working for me either on the very latest Insider - but I noticed the bootloader is "locked"* so there's not much we can do:

*running bcdedit reports some issue

I'm wondering if I install WOA and choose to NOT keep windows 10 Mobile that the deployment might work differently and allow us to mess around with bcdedit or even get WSL2 to work, etc. Ultimately, we need to learn more about how WOA Deployer project works and how they manipulated the bootloader as well as the possibility of accessing an actual BIOS user interface akin to the Raspberry Pi3 solution; in other words what is the difference between booting Win10 on Rpi3 vs. Lumia 950/XL?