BSOD lumia 950

Stuck at some Point? Your Lumia is already dead? Maybe others can help you!
Post Reply
anderek79
Posts: 3
Joined: Sun Dec 22, 2019 5:17 pm

BSOD lumia 950

Post by anderek79 » Wed Dec 25, 2019 7:38 pm

Hi all, I completely installed windows 10 Pro arm to my Lumia but when is windows booting mobile fall down to this blue screen: DRIVE PNP WATCHDOG. Please Help me :cry: . Thanks.
Attachments
BSOD_lumia950.jpg
BSOD_lumia950.jpg (90.69 KiB) Viewed 14861 times
0 x

dengchanggang
Posts: 1
Joined: Thu Dec 26, 2019 4:36 am

Re: BSOD lumia 950

Post by dengchanggang » Thu Dec 26, 2019 4:42 am

me,too。
Did you resolve it?
0 x

anderek79
Posts: 3
Joined: Sun Dec 22, 2019 5:17 pm

Re: BSOD lumia 950

Post by anderek79 » Thu Dec 26, 2019 10:24 am

I read too many disscusion about this problem and i think that is wrong wrote driver for touch or wrong eMMC memory in mobile. I will support this author of WOA project but only when i see functional mobile in my hand with win 10 arm... I have a second lumia 950xl but I afraid install woa project to this phone for next blue screen...
0 x

The_GTA
Posts: 93
Joined: Mon Sep 02, 2019 9:17 am
x 52
x 30

Re: BSOD lumia 950

Post by The_GTA » Fri Dec 27, 2019 9:16 pm

What Windows 10 build did you try? What driver pack version did you install?

Known driver packs: 1909, 1910, ????
I did install build 19038 last weekend using 1910 driver pack and it worked.
0 x

anderek79
Posts: 3
Joined: Sun Dec 22, 2019 5:17 pm

Re: BSOD lumia 950

Post by anderek79 » Sun Dec 29, 2019 6:25 pm

I installed yesteryday new build 1910 and still the same. Maybe wrong mobile...
0 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sun Dec 29, 2019 6:29 pm

This is happening for me too lately - seems the drivers were updated 7/35 days ago - a likely culprit.

How to choose a driver pack?
EDIT: I found out how to choose a driver pack on Github - but not using the WOA Deployer app.

Will try to come up with a script to temporarily repair this whilst waiting for a fix...
EDIT: can't be sure it is the drivers and not something else to do with the UEFI packages!

Code: Select all

# Downloading resources
FetchAzureDevOpsArtifact "LumiaWOA;Boot Shim;3;UEFI Loader for 8992 and 8994"
FetchGitHubLatestReleaseAsset "https://github.com/WOA-Project/Lumia950XLPkg" "MSM8994.UEFI.Lumia.950.XL.zip"
FetchGitHubBranch "https://github.com/WOA-Project/MSM8994-8992-NT-ARM64-Drivers" "1910-release-svc"
FetchGitHubBranch "https://github.com/WOA-Project/Support-Desktop-Drivers" "1910-release-svc"
FetchGitHubBranch "https://github.com/WOA-Project/Specifics-MMO-Drivers" "1910-release-svc"
FetchGitHubBranch "https://github.com/WOA-Project/Specifics-Cityman" "1910-release-svc"
# Configuring device
Copy "Downloaded\MSM8994.UEFI.Lumia.950.XL\ELF\UEFI.elf" "[EFIESP]\"
Copy "Downloaded\UEFI Loader for 8992 and 8994\ARM\Debug\BootShim.efi" "[EFIESP]\EFI\boot\"
ConfigureBCD
InstallDevMenu "Core\Developer Menu\"
# Deploying Windows
DeployWindows
MakeWindowsBootable
CopyDirectory "[DPP]" "[Windows]\DPP"
# Injecting Drivers
InjectDrivers "Downloaded\Support-Desktop-Drivers"
InjectDrivers "Downloaded\MSM8994-8992-NT-ARM64-Drivers\msm8992-8994"
InjectDrivers "Downloaded\MSM8994-8992-NT-ARM64-Drivers\msm8994"
InjectDrivers "Downloaded\MSM8994-8992-NT-ARM64-Drivers\configurations\soc-final"
InjectDrivers "Downloaded\Specifics-MMO-Drivers"
InjectDrivers "Downloaded\Specifics-Cityman"
DisplayMarkdown "Downloaded\MSM8994-8992-NT-ARM64-Drivers\README.md"
A lot of those files have had updates - just not bootshim.efi nor most of the drivers under 1910-release - just the graphics driver from about 2 months ago. That's what leads me to suspect it's something else in the UEFI package that's changed.
0 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sun Dec 29, 2019 8:30 pm

I've got it working using a hotchpotch of the latest 1912 drivers for the 950 XL.

edit: drivers link removed - no longer necessary.
Last edited by gilius on Sat Jan 04, 2020 12:05 pm, edited 3 times in total.
1 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sun Dec 29, 2019 9:11 pm

FALSE ALARM - It's only the latest Windows Insider(s) that have a problem!

That's probably why the newer drivers (1912) were working compared to the 1910 drivers - unless the issue was fixed in the last half hour (unlikely).
0 x

The_GTA
Posts: 93
Joined: Mon Sep 02, 2019 9:17 am
x 52
x 30

Re: BSOD lumia 950

Post by The_GTA » Sun Dec 29, 2019 9:25 pm

Interesting findings, gilius! Thank you for keeping me and us up to date. Was hoping to get some details about gus33000's drivers (maybe bugs we could report) but you seem to disregard that notion.
0 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sun Dec 29, 2019 9:39 pm

np - it's good practice to try to understand the manual method of installing this in case WOA Deployer was ever to go offline - heaven forbid!

The detailed logs are very helpful coupled with the guide I found so I think there's potential to build on the above script. Next I am going to try to dual boot without using the app:
Image

Code: Select all

2019-12-29 22:19:26.614 +00:00 [Debug] Running process: { Command: "C:\windows\SysNative\bcdedit.exe", Arguments: "/STORE \"G:\EFI\Microsoft\Boot\BCD\" /set {7619dcc9-fafe-11d9-b411-000476eba25f} description \"Windows 10 Phone\"", workingDirectory: "" }
2019-12-29 22:19:26.688 +00:00 [Debug] End of process. Execution summary: { ExitCode: 0, OutputOutput: "", ErrorOutput: "" }
2019-12-29 22:19:26.688 +00:00 [Debug] Running process: { Command: "C:\windows\SysNative\bcdedit.exe", Arguments: "/STORE \"G:\EFI\Microsoft\Boot\BCD\" /set {7619dcc9-fafe-11d9-b411-000476eba25f} path \"\windows\system32\boot\winload.efi\"", workingDirectory: "" }
2019-12-29 22:19:26.781 +00:00 [Debug] End of process. Execution summary: { ExitCode: 0, OutputOutput: "", ErrorOutput: "" }
2019-12-29 22:19:26.781 +00:00 [Debug] Running process: { Command: "C:\windows\SysNative\bcdedit.exe", Arguments: "/STORE \"G:\EFI\Microsoft\Boot\BCD\" /default {7619dcc9-fafe-11d9-b411-000476eba25f}", workingDirectory: "" }
2019-12-29 22:19:26.855 +00:00 [Debug] End of process. Execution summary: { ExitCode: 0, OutputOutput: "", ErrorOutput: "" }
2019-12-29 22:19:26.855 +00:00 [Debug] Running process: { Command: "C:\windows\SysNative\bcdedit.exe", Arguments: "/STORE \"G:\EFI\Microsoft\Boot\BCD\" /displayorder {7619dcc9-fafe-11d9-b411-000476eba25f} /addfirst", workingDirectory: "" }
Hmmm.... I think I'll try this on my normal 950 first! :oops:
0 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sat Jan 04, 2020 12:07 pm

I can confirm this BSOD is only in the latest Windows Insider:
19536.1000.191211-1446.RS_PRERELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO

The ones before that are fine:
19041.1.191206-1406.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
19037.1.191202-1231.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
19035.1.191126-1316.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
19033.1.191123-1729.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
19030.1.191119-1609.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
19028.1.191115-1325.VB_RELEASE_CLIENTPRO_OEMRET_A64FRE_EN-GB.ISO
...etc.

The 19536 will probably work too - we just need to find out the offending driver till it gets updated by the WOA Deployer team.
1 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Sat Jan 04, 2020 9:34 pm

Seems to be a problem with the bootloader - nothing to do with the drivers - same BSOD with ZERO drivers injected!
0 x

User avatar
AMR1
Posts: 9
Joined: Wed Jun 05, 2019 10:08 pm
Location: Austin, Texas, USA
x 2
x 3

Re: BSOD lumia 950

Post by AMR1 » Mon Feb 03, 2020 11:28 pm

I have been getting a BSOD (DRIVER PNP WATCHDOG) on my 950XL when trying to install any OS later than 19041.21, which I assume is the same issue that y'all are discussing. I keep trying to upgrade, then falling back to 19041.21
1 x

The_GTA
Posts: 93
Joined: Mon Sep 02, 2019 9:17 am
x 52
x 30

Re: BSOD lumia 950

Post by The_GTA » Tue Feb 04, 2020 3:46 pm

1 x

User avatar
AMR1
Posts: 9
Joined: Wed Jun 05, 2019 10:08 pm
Location: Austin, Texas, USA
x 2
x 3

Re: BSOD lumia 950

Post by AMR1 » Sat Feb 08, 2020 9:42 pm

The_GTA wrote:
Tue Feb 04, 2020 3:46 pm
@AMR1 see https://github.com/WOA-Project/MSM8994- ... /issues/68
Do you know if Manganese builds will be supported in the future, or is 19041.21 the end of line for Lumia 950XLs running WOA?
0 x

The_GTA
Posts: 93
Joined: Mon Sep 02, 2019 9:17 am
x 52
x 30

Re: BSOD lumia 950

Post by The_GTA » Sat Feb 08, 2020 10:24 pm

AMR1 wrote:
Sat Feb 08, 2020 9:42 pm
Do you know if Manganese builds will be supported in the future, or is 19041.21 the end of line for Lumia 950XLs running WOA?
I cannot always read the cryptic tweets of Gustave Monce (gus33000) but please look at this:



Possible meanings:
1) he got Manganese builds to boot again although glitchy
2) he got USB-C HDMI to work finally

Sorry but I cannot give you a 100% guarrantee. Gustave seems to work on getting all the Lumia's supplied with WoA currently.
1 x

gilius
Posts: 86
Joined: Sat Sep 28, 2019 7:12 pm
x 11
x 56

Re: BSOD lumia 950

Post by gilius » Tue Feb 18, 2020 9:41 pm

2004 Feature Upgrade is working! But not the mobile connection unfortunately...
1 x

Post Reply